Maintenance Notif
Incident Report for Ubden® Global Services Status
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2022 - 05:39 UTC
Investigating
Trakyum Ticaret Services and its servers are down for maintenance.
Posted Apr 08, 2022 - 05:36 UTC
This incident affects: Trakyum Trade Services.