Data Processing Delays - Reporting Tools Affected

Incident Report for Ubden® Global Services Status

Update

We are continuing to investigate this issue.
Posted Dec 19, 2024 - 06:34 UTC

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Apr 08, 2022 - 05:40 UTC
This incident affects: API Services and Trakyum Trade Services.